Back to overview
Resolved

Version Upgrade - v1.5.9

Jul 8, 2026 at 5:00am UTC  –  Jul 8, 2026 at 6:14am UTC
Affected services
app.iotwatt.io
Web App
Socket Service
Main Backend Service

Resolved
Jul 8, 2026 at 6:14am UTC

We've completed the production update.

Updated
Jul 8, 2026 at 6:14am UTC

Maintenance ended

Created
Jul 8, 2026 at 5:00am UTC

The IoTWatt platform will be unavailable for the next 2 hours as we upgrade our system to a new version, to optimize and improve our customer's energy experience. We apologize for any inconvenience caused.