Back to overview
Maintenance

Version Upgrade - v1.5.4

Apr 20, 2026 at 10:00am UTC  –  Apr 20, 2026 at 3:00pm UTC
Affected services
docs.iotwatt.io
app.iotwatt.io
Web App
Socket Service
Main Backend Service
admin.iotwatt.io

Resolved
Apr 20, 2026 at 3:00pm UTC

Maintenance ended

Created
Apr 20, 2026 at 10:00am UTC

Scheduled Maintenance Notice**

We will be performing a planned infrastructure upgrade to improve data performance and reliability on the IoTWatt platform.

When: 18:00 - 23:00 MYT (GMT+8)
Expected Duration: 5 hours

What's changing: We're upgrading our data infrastructure to support a hot/warm data lifecycle — this will improve query speeds for recent data and ensure long-term historical data remains accessible and cost-efficient.

Impact: Brief interruption to dashboard data and report generation during the maintenance window. All historical data will remain intact.


                                                                  ..;===+.
                                                            .:=iiiiii=+=
                                                         .=i))=;::+)i=+,
                                                      ,=i);)I)))I):=i=;
                                                   .=i==))))ii)))I:i++
                                                 +)+))iiiiiiii))I=i+:'
                            .,:;;++++++;:,.       )iii+:::;iii))+i='
                         .:;++=iiiiiiiiii=++;.    =::,,,:::=i));=+'
                       ,;+==ii)))))))))))ii==+;,      ,,,:=i))+=:
                     ,;+=ii))))))IIIIII))))ii===;.    ,,:=i)=i+
                    ;+=ii)))IIIIITIIIIII))))iiii=+,   ,:=));=,
                  ,+=i))IIIIIITTTTTITIIIIII)))I)i=+,,:+i)=i+
                 ,+i))IIIIIITTTTTTTTTTTTI))IIII))i=::i))i='
                ,=i))IIIIITLLTTTTTTTTTTIITTTTIII)+;+i)+i`
                =i))IIITTLTLTTTTTTTTTIITTLLTTTII+:i)ii:'
               +i))IITTTLLLTTTTTTTTTTTTLLLTTTT+:i)))=,
               =))ITTTTTTTTTTTLTTTTTTLLLLLLTi:=)IIiii;
              .i)IIITTTTTTTTLTTTITLLLLLLLT);=)I)))))i;
              :))IIITTTTTLTTTTTTLLHLLLLL);=)II)IIIIi=:
              :i)IIITTTTTTTTTLLLHLLHLL)+=)II)ITTTI)i=
              .i)IIITTTTITTLLLHHLLLL);=)II)ITTTTII)i+
              =i)IIIIIITTLLLLLLHLL=:i)II)TTTTTTIII)i'
            +i)i)))IITTLLLLLLLLT=:i)II)TTTTLTTIII)i;
          +ii)i:)IITTLLTLLLLT=;+i)I)ITTTTLTTTII))i;
         =;)i=:,=)ITTTTLTTI=:i))I)TTTLLLTTTTTII)i;
       +i)ii::,  +)IIITI+:+i)I))TTTTLLTTTTTII))=,
     :=;)i=:,,    ,i++::i))I)ITTTTTTTTTTIIII)=+'
   .+ii)i=::,,   ,,::=i)))iIITTTTTTTTIIIII)=+
  ,==)ii=;:,,,,:::=ii)i)iIIIITIIITIIII))i+:'
 +=:))i==;:::;=iii)+)=  `:i)))IIIII)ii+'

.+=:))iiiiiiii)))+ii;
.+=;))iiiiii)));ii+
.+=i:)))))))=+ii+
.;==i+::::=)i=;
,+==iiiiii+,
+=+++;